Sub-menu items not saving!

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #6322 Reply
    Barry Richardson
    Guest

    I have a Main Menu heading, “Free Stuff”, and am trying to add 7 sub-menu items. I select Theme Location/Primary and click Save Menu. After the menu has saved, I find that 1 or 2 of the latter sub-menu items are missing, although I saved the menu. Why are these saved sub-menu items disappearing?

    I first added the sub-menu items from the Pages list on the left; the last sub-menu item was missing after the save.
    I then deleted all the sub-menu items and re-inserted them as Links, with a similar result – only 5 of the 7 sub-menu items were there after saving the menu; the latter 2 items were missing.

    #6337
    Ron
    Keymaster

    I can’t reproduce your issue and I see that you got one parent item that shows more than 10 child items just fine.
    Try disabling your plugins and/or clearing your browser cache.

    #6340
    Barry Richardson
    Guest

    I have cleared my cache, history – everything – and disabled all my plugins; it made no difference. I am still having problems with the Menu. For some reason it will not include more than the first 5 sub-items under “Free E-books” – subsequent items just disappear when I Save Menu.

    I tried adding one of the other items in a separate tab – “Recipes” – which appears in the Main Menu – but nothing happens when I click it. I tried adding it from the Pages list on the left, and also as a Link (URL), but it stays dead, although the URL works when I paste it into my browser. I’ve never had this problem before with this theme.

    #6342
    Barry
    Guest

    Ron – I just did a test – added some new items to the menu bar, saved the Menu and none of the new items was present in the Menu bar when I viewed the website.

    It seems that the Menu is only “active” up to a certain point; “Recipes” is there but not “live”, and subsequent items do not appear at all.

    Should I change my theme to get rid of this problem?

    #6356
    Ron
    Keymaster

    Ron – I just did a test – added some new items to the menu bar, saved the Menu and none of the new items was present

    I also did a little test. You can see on my menu that I’ve temporarily added up to 12 menu items totaling 15 sub-menu items under WP Theme.

    I highly doubt that your issue could be theme-related. You mentioned that:

    I’ve never had this problem before with this theme.

    What changed then? You didn’t edit the theme files, right? The only things I could think of in your case is that 1) You’ve been adding menu items to the wrong menu. OR 2) You have a caching plugin that serves a static page.

    “Recipes” is there but not “live”

    Your “Recipe” menu item doesn’t have any URL set to it.

    Should I change my theme to get rid of this problem?

    Sure, if you find that more convenient. I’m also curious to see if switching to one of the default themes (twentyfifteen, twentyfourteen…) does solve your issue.

    #6357
    Barry
    Guest

    I like the theme and wouldn’t want to change it, I just thought it might help to “start over”, so to speak, with a new one.

    I am only using 1 menu.

    I have 84 items in the full Menu; 83 have their links intact but the last one (The Creatine Report) has lost its URL. I wouldn’t like to re-do the entire menu only to find that the problem persists!

    About my plugins – I don’t seem to have any “caching plugin” – these are all the plugins I have installed:

    Akismet
    Amazon Affiliate Link Localizer
    Contact Form by ContactMe.com
    Google XML Sitemap
    Platinum SEO Pack
    PlusCaptcha
    Pretty Link Lite
    Shareaholic – share buttons, analytics, related content
    Slide Out Tab
    TablePress
    Triberr
    UpdraftPlus – Backup/Restore.
    Lazy Load for Videos

    I want to mention that I changed the theme options from 2 columns to 3 a couple of days ago in order to have 2 sidebars, and I adjusted the Container Width accordingly; would this have had any effect on the menu bar?

    #6358
    Ron
    Keymaster

    …would this have had any effect on the menu bar?

    No.

    –Update–
    A little google search and this comes up… Your issue might be related to your server. This is an old post but might still be applicable to your setup.
    http://stackoverflow.com/questions/12777433/wordpress-menu-items-not-being-saved
    http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-custom-menu-items-limit-in-wordpress/

    #6360
    Barry
    Guest

    Thank you, Ron!

    I thought there must be a “limit” set somewhere. I’m going to contact my hosting provider (I have shared hosting) and ask them to do the adjustment.

    Best regards!

Viewing 8 posts - 1 through 8 (of 8 total)
Reply To: Sub-menu items not saving!
Your information: