Mobile compatibility issues

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #3109 Reply

    Anonymous

    Hi Ron,
    It’s Jenny again 😉

    2 quick questions, if you don’t mind:

    1) I saw that updated the asteroid to 1.12 for wp 3.6
    Currently I am using asteroid to 1.11 for wp 3.6, I am a bit afraid to upgrade the theme because I tweaked the code a bit, without making a child theme!
    However, so far I could not see any changes compared to the way it worked with wp 3.5.2 , did I miss something?
    Is it crucial to upgrade to 1.12 (while using it with wp 3.6) or maybe it’s not that necessary?

    2) I know that you built this theme to be responsive…
    However, when accessing my site via android – it does not look good at all with vertical position, the phone’s browser display only one column of my site, the other column is to the right (and not below) so in order to see it – you need to scroll the browser to the right, VERY uncomfortable
    If you hold the phone in an horizontal position – the site will look good.

    I never tried it with iPhone but I believe that it’s the same story with iphone as well…

    url is artikelskribenten dot se

    Any idea how to fix this?

    Best,
    Jenny

    #3111

    Ron
    Keymaster

    Hi Jenny,

    1.) When users upgraded to WordPress 3.6 there was an error message that appears on the default comments section. Asteroid 1.1.2 fixes this. I guess those users that use other commenting systems like disqus or jetpack weren’t affected. So this is not really a crucial update if you’re not having any errors on the comment section. Anyway I’m not seeing any major modifications on your site. If you plan to make more, then using a child theme now is really the best approach.

    2.) I unfortunately don’t have any device to test it on right now. You could try to visit this site that uses asteroid theme: http://gamenovice.com/
    If it displays correctly on any position on your mobile device then I think it’s your own site that is causing the issue.

    Your site shows a horizontal scroll bar on the bottom when viewed on a desktop screen. There shouldn’t be any horizontal scroll bars. I suspect that it is caused by the plugins you are using. You could try deactivating them temporarily and see if the site displays correctly.

    Ron

    #3121

    Anonymous

    Thanks a lot Ron,

    Well, thanks for explaining the version update reason, it does not really apply to my because I am not using comments at all 🙂

    Regarding the mobile compatibility issues – thanks for paying my attention for the horizontal scroll bars, I did not pay attention for this before.
    I think that these horizontal scroll bars and the fact that my site look terrible on a smartphone – they both comes from the same issue.

    I tried your advice and disable the plugins, then loaded my site with ie, ff, chrome and safari – all 4 still show the horizontal scroll bars 🙁

    Where else would you recommend me to look for?
    I am about to build a huge site and it’s important for me to fix such issues right from the start, the site must look good on phones and it should not show horizontal scroll bars at all

    Please help Ron…

    #3124

    Anonymous

    Can it be something with the logo’s length?
    I am not quite sure but I think I slightly tweaked on or two of the theme php files in the past, something to do with the header and the header image…

    Do you mind having another look at the site and tell me what you think?

    If it can help, I can send you the tweaked theme files…

    #3125

    Ron
    Keymaster

    You could try a few more tests.
    –When you disabled the plugins you also disabled the caching plugin right? While the plugins are disabled clear your browser cache then check.

    –You could also try to temporarily disable your text widget on the sidebar then check.

    –Temporarily remove your footer text and check. You’re using the <font> tag. This could be rewritten in a better way.

    —Edit—
    I’m seeing extra </a> tags on the footer text. That could be it.

    #3130

    Anonymous

    Thanks Ron,

    I am not using any wp caching plugin!

    Tried to clean the footer completely, then clean browser cache – does not work
    Tried to disable all active plugins, then clean browser cache – does not work
    Tried to remove the text widget, then clean browser cache – does not work

    Getting nuts here…

    #3132

    Anonymous

    OK, I gave up – I just upgraded to Astroid 112, it fixed the horizontal scroll bars but it also killed all design modifications I did before 😉
    At least now I know what cause the horizontal scroll bars issue – it was my modifications, no plugins/widget

    #3133

    Anonymous

    And it did NOT fix the mobile compatibility issues

    #3134

    Ron
    Keymaster

    I am not using any wp caching plugin!

    If you right click your page then click “View Source” you’ll see

    WP-Super-Cache
    <!-- Dynamic page generated in 0.723 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2013-09-08 10:02:32 -->
    #3135

    Anonymous

    Yes, but this plugin is not active

    #3136

    Anonymous

    I struggle with this a lot…
    Eventually I managed to solve the horizontal scroll bars issue but the site still does not look good on phones
    I checked the other site you mentioned and it appear ok on phones, I have no idea why mine is not the same
    I gguess I will have to look for a 3ed party plugin or some kind of “mobile switcher” to display my site properly on mobiles phones 😉

    Thanks a lot for your kind help Ron,
    Jenny

Viewing 11 posts - 1 through 11 (of 11 total)
Reply To: Mobile compatibility issues
Your information: