Frontier Theme More Tag Help

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #7240
    Wesley Lovell

    I need to customize the <!–more–> tag in the Frontier theme. Specifically, I want to style it and also change the verbiage. However, I’m having trouble getting it to change. I made the following change in both the loop-blog and loop-single files, but nothing changed. It’s the only place I can find “the_content” tag to modify.

    I changed:
    <?php the_content(); ?>

    <?php the_content(‘<span class=”Read_More”>There’s still more. Click here to continue reading…</span>’); ?>

    Can anyone help me figure this out? Is there something preventing this change from going into effect that would require the creation of a child theme to force in a function? I tried using the guide at, but ultimately neither the change to functions.php or the change to the_content worked.


    That works just fine on my tests.
    Make sure you’re using an apostrophe(‘) instead of a backquote(`)

    <?php the_content('<span class="Read_More">There’s still more. Click here to continue reading…</span>'); ?>

    But why not just use this function and modify the funtions.php instead of the 2 other php files


    function modify_read_more_link() {
        return '<a class="more-link" href="' . get_permalink() . '">There\'s still more. Click here to continue reading...</a>';
    add_filter( 'the_content_more_link', 'modify_read_more_link' );
    Wesley Lovell

    The first change ended up stopping the entire site from working. I know I used the single quote, so not sure what that’s about.

    As to the second option, I tried putting it in a few places and each time, it made my entire back-end stop working. The site was still there, but it wasn’t showing the new read more text and when I tried to navigate in wordpress, it would give me an error saying it couldn’t be accessed. So, either I was putting it in the wrong spot or there’s something else causing problems.


    Did you try copying/pasting the code from my example above without editing it? Those 2 example works fine for me so I find it strange that it would throw an error on your side. Have you edited the theme files in any other way?

    As to the second option, I tried putting it in a few places and each time, it made my entire back-end stop working.

    The first option should be placed on loop-blog.php

    The second option should only be placed in the functions.php. Adding it at the end of the file should be safe.

    Don’t use both code at the same time. I recommend going with the 2nd option, editing the functions.php (using a child theme would be best)

    If on your test no change is showing and you are using a caching plugin then it could be a caching issue where an old copy of the page is shown instead of reflecting the changes.

    As with any change involving editing theme files, using a child theme is best practice. It’s not required as long as you know the risks of not using one.

    Wesley Lovell

    Thanks. That worked. I’m guessing it was the apostrophe that was causing the errors before. I’ll have to do up a child theme later, but for now, I put it at the end of the functions file. I haven’t made any other adjustments to the theme itself, so it won’t be hard to fix (and I have to do it again if there’s an update (at least until I get it in a child theme).

    As an aside, I know this is a fixed-width theme, but is there any easy way of modifying that to make it slightly wider?


    On Frontiers Option -> Layout -> Container Width
    Though that only goes up to 1400px. If that’s not big enough then there are css codes to do that.

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Frontier’ is closed to new topics and replies.