[firstchild_redirect] showing on mobile

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #5613 Reply
    Michael Sanders
    Guest

    Hiya,

    First, great theme! Thanks for making it available. I’m working on a redesign on the Punkin Chunkin site (yes, the guys in Delaware that throw pumpkins nearly a mile using ari cannons, trebuchets and catapults.)

    I’m having no problems with it as far as desktop browsers go, but when viewed on mobile and I select a submenu, the page is displayed as [firstchild_redirect]. Can you advise me on what might cause this?

    Thanks in advance!

    #5639
    Ron
    Keymaster

    I don’t understand what you mean by “[firstchild_redirect]”.

    Does your posts show “[firstchild_redirect]” on the content area? That may be a shortcode of some sort. Check your plugins.

    Or do you mean that you can’t select sub-menu items on mobile. If so, then check this https://ronangelo.com/frontier-documentation/#doc-setting-menus

    #5645
    Michael Sanders
    Guest

    OK, I found a reference to it at http://stackoverflow.com/questions/10416218/webbrowser-does-not-redirect that has a link to a Microsoft document. This appears to be a code issue when the theme is used on a Windows Phone (I have a Nokia 1020.) Got any ideas how to resolve this?

    #5663
    Ron
    Keymaster

    Got any ideas how to resolve this?

    Sorry, I have no idea. Also, the link you posted has no mention of any [firstchild_redirect] and it’s also posted on the C# section of stackexchange and not PHP which is what WordPress and WP Themes are made of.

    This appears to be a code issue when the theme is used on a Windows Phone.

    Does my site (ronangelo.com) display the same issue when viewed on your phone?

    #5670
    Michael Sanders
    Guest

    No problems showing up on yours that I see. Now I’m really confused!

    #5673
    Michael Sanders
    Guest

    OK, after some looking at it a bit more, I noticed the following:
    1. From root/home menu, all appears correct, but any submenu items selected have the issue previously reported.
    2. What I didn’t notice before is that the menu is drawn, then the page is redrawn again with the menu collapsed and the issue with the error remains in the content area.

    I’m wondering if it is a plugin compatibility issue where one plugin isn’t playing along nice with the others.

    #5674
    Michael Sanders
    Guest

    Also have tried deactivating all of the plugins and still have the same result.

    #5675
    Michael Sanders
    Guest

    Well, after getting nowhere fast, I decided to start over. Have uninstalled/reinstalled WP and have applied the theme. We’ll see how it goes from here…

    #5677
    Michael Sanders
    Guest

    OK, so I’ve reinstalled, rebuilt the menus and the redirect line isn’t showing anymore. That’s good. Still playing with this…

    #5678
    Ron
    Keymaster

    OK, so I’ve reinstalled, rebuilt the menus and the redirect line isn’t showing anymore. That’s good. Still playing with this…

    Have you installed the same plugins yet? Maybe one of those interacts with the content of a post.

    #5680
    Michael Sanders
    Guest

    OK, all appears to be working now. My last mistake was making the top level menu a page instead of a link with a value of “#”. Doing that got everything working well – so far. Being careful to only add one plugin at a time and checking to make sure that it doesn’t introduce a problem. Thanks!

Viewing 11 posts - 1 through 11 (of 11 total)
Reply To: [firstchild_redirect] showing on mobile
Your information: