WP Frontier Theme Error

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #7381 Reply

    John

    Hi,

    I want to install the WP Frontier Theme v1.2.5 to my WordPress 4.7.2. After the install of the Theme I can’t read or change the Frontier Options “Blog View, Single View, Widget, …”. When i start the Error-Logging on the Web Server, get I the following Error-Message:
    Warning: Illegal string offset ‘body’ in /../wp-content/themes/frontier/functions.php on line 202
    Warning: Illegal string offset ‘below_menu’ in /../wp-content/themes/frontier/functions.php on line 224
    Warning: Illegal string offset ‘before_content’ in /../wp-content/themes/frontier/functions.php on line 235
    Warning: Illegal string offset ‘after_content’ in /../wp-content/themes/frontier/functions.php on line 245
    Warning: Cannot modify header information – headers already sent by (output started at /../wp-content/themes/frontier/functions.php:202) in /../wp-includes/pluggable.php on line 1179

    My Server Config is:
    ——————–
    Apache Version : Apache/2.2.22 (Ubuntu)
    Server API : CGI/FastCGI
    PHP Version : 7.1.1
    MySQL Version : 5.5.54 (mysqli)

    Can you say me what is here the Problem and how can I fix it.

    Thanks for you help.

    Best regards
    John

    #7384 Reply

    Ron
    Keymaster

    I can’t read or change the Frontier Options

    Can you elaborate? What exactly happens when you visit the page?

    I can’t recreate the error you’re having. Have you tried visiting the options page on a different browser. Try clearing your browser’s cache.

    #7385 Reply

    John

    Hello Ron,

    when I visit the Frontier Options and click the Tab “Blog View” the Checkboxes of “Article Elements” are all empty (not checked). The same Problem is on the Tab “Single View” with the Checkboxes of “Post Elements” and “Page Elements”. The Tab “Widgets” with the Checkboxes of “Widget Areas” is the same Problem. The Radio-Options of “Footer Widget Columns” works fine.
    Wenn I choose the checkboxes and click on the Button “Save Options” I become the Message “Options saved.” but all checkboxes are now again empty.

    When I installed the same WordPress and the same Theme on the other Webhosting with the follow Server-Configs, I have no Problems and it works fine:

    Apache Version : Apache/2.2.15 (CentOS)
    Server API : CGI/FastCGI
    PHP Version : 5.3.29
    MySQL Version : 5.1.73 (mysql + mysqli)

    Apache Version : ???
    Server API : FPM/FastCGI
    PHP Version : 7.0.14-nmm1
    MySQL Version : 5.0.12-dev (nur mysqli)

    I think that is a Problem with the newer MySQL-Database v5.5.54. Or what you think?

    Best regards
    John

    #7386 Reply

    Ron
    Keymaster

    I don’t have a MySQL 5.5.54 to test but the server this blog is running on has MySQL 5.1.73 and my wampserver uses MySQL 5.7.11 and the theme works fine on both. I suspect it’s something else unique to that one web host.

    #7391 Reply

    John

    Hello Ron,

    I think I have found the problem. The Problem is not the MySQL Version, I think it is the PHP Version 7.1.1 or newer. I have tested die PHP Version 7.0.15 an all errors are gone and the Theme works fine. Can you make a Test with the XAMPP Server Package “xampp-portable-win32-7.1.1-0-VC14.7z”. After saving the Options i become with the XAMPP Package a lot of error messages.
    I hope you can fix the error. It would be nice if I could use the theme with the latest PHP Version.

    Best regards
    John

    #7392 Reply

    John

    Hello Ron,

    I have downgrade the PHP Version from 7.1.1 to 7.0.7 from my Webhosting and now all problems gone. Can you fix the Problem in the next Version of the Frontier Theme 1.2.6?

    Thanks for your help.

    Best regards
    John

    #7393 Reply

    Ron
    Keymaster

    Ok. I’ve made some changes for the next update.

    Thanks,
    Ron

Viewing 7 posts - 1 through 7 (of 7 total)
Reply To: WP Frontier Theme Error
Your information: