Hide ALL posts on front page and only display widgets

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #7170 Reply

    ANthony

    Hi
    Love the Frontier theme but I need some help.

    I have a 3 column layout (a sidebar either side an the content box in the middle).
    I want to add just WIDGETS to the content section. I have no posts to display in this area. It shows “nothing found” down the bottom. is there a way of hiding all posts etc from the front page

    I am aware of changing to a static page but this doesn’t allow the widgets I want to use.

    Any suggestions?

    Thanks

    #7171 Reply

    Ron
    Keymaster

    I am aware of changing to a static page but this doesn’t allow the widgets I want to use.

    That is the only way I can think of. What kind of widgets are you talking about? I’m curious why they can’t be used.

    #7175 Reply

    ANthony

    Thanks

    I use another theme that has the option of hiding posts and pages from the from page which is handy.
    I currently use image and slideshow widgets in the “before content’ widget area on the homepage.
    If you have a look at the site you will see “view our complete range” at the bottom, this is a post title (that has a link attached). This was the only way I could have something there that didnt look out of place and hid the “nothing found” error message. I want to hide this altogether if possible.

    I also dont have the option of selecting to display a Static Page on the front.ive been into Settings>Reading> etc but no option.

    Thanks for any help or suggestions?

    #7180 Reply

    Ron
    Keymaster

    I also dont have the option of selecting to display a Static Page on the front.ive been into Settings>Reading> etc but no option.

    That’s weird since it’s the very first option on the page “Front page displays”. Are you using an admin account?

    I also don’t see what the first problem is. On my test I set a static page to be the front page then I edit that page so it has no Title and Content but I don’t see any “nothing found” error.

    #7182 Reply

    ANthony

    hi, thanks for your reply. yes I am the admin of the account.

    I have included a screen shot of the options I have on the Settings>’Reading’ menu.

    I can not see the option of displaying only a static page. I use Frontier on another website and am familiar with where I is. Not sure what I’m doing rong or why I cant see it
    screenshot

    if I could find a way of setting a static page as the front page then could just do as you suggested

    edit that page so it has no Title and Content

    thanks

    #7183 Reply

    Ron
    Keymaster

    Have you created any pages? If not, create one then publish it. Go back to the Reading setting to see if the option has appeared.

Viewing 6 posts - 1 through 6 (of 6 total)
Reply To: Hide ALL posts on front page and only display widgets
Your information: