Rule #1 – This is my blog.

Asteroid Theme Fix for IE8 and Below

When I made the Asteroid Theme for WordPress, I wasn’t planning on IE-proofing it. The plan was to simply make sure that it works on most modern browsers like Firefox, Google Chrome, Opera and IE9 or later.

It turns out that the theme’s menu / navigation is not properly displayed on previous versions of Internet Explorer like IE8, IE7, IE6 and so on. There were also other various design irregularities. This uncompromising behavior is peculiar to Internet Explorer or Internet Destroyer as some would call it.

IE Issue Fix

Fortunately a simple WordPress plugin offers a quick fix as pointed out by an Asteroid Theme user. Credits to Eyal.

  • Go to your Admin Page -> Plugins -> Search
  • Search for Modernizr
  • Install. Fixes the issue like magic.

Modernizr is a small JavaScript library that detects the availability of native implementations for next-generation web technologies, i.e. features that stem from the HTML5 and CSS3 specifications.

Modernizr Off
Modernizr On

Share This Post :

1 Comment

Add a Comment

Leave a Reply

Please write your comments in english. I delete anything that even remotely resembles spam.

Note: When posting code, enclose it in pre and code tags.
e.g. <pre><code> Add code here </code></pre>

ronangelo © 2014 Frontier Theme
css.php